Back to overview
Resolved

Hosting Maintenance

Jul 13, 2026 at 10:45pm UTC  –  Jul 14, 2026 at 1:50am UTC
Affected services
Website
API

Resolved
Jul 14, 2026 at 1:50am UTC

Maintenance ended

Created
Jul 13, 2026 at 10:45pm UTC

Labixe Host infrastructure maintenance